Time to UPDATE your MT4 platform

IMPORTANT INFORMATION | PLEASE READ CAREFULLY As of June 1, 2012 (Today), MetaQuotes (the developers of MetaTrader4) will no longer be supporting MT4 terminals running any versions below build 416. If you are using a version which is older than build 416, you need to update your MT4 to the latest available version. In order [...]

Check out how our tight ECN Spreads Compare to other Forex Brokers

Quick Preview:   The full Spread Analyzer is available on our web site at: http://www.fxpig.com/index-page=spreads.aspx.html